install PHP

Since I didn’t intall the devel packages, some extra RPMs need to be installed for PHP installation.

A bunch of RPMs that need to be installed:
flex-2.5.4a-33.i386.rpm
libxml2-devel-2.6.16-6.i386.rpm
zlib-devel-1.2.1.2-1.2.i386.rpm
mysql-devel-4.1.12-3.RHEL4.1.i386.rpm
openssl-devel-0.9.7a-43.8.i586.rpm
krb5-devel-1.3.4-27.i386.rpm
e2fsprogs-devel-1.35-12.3.EL4.i386.rpm
mysql-bench-4.1.12-3.RHEL4.1.i386.rpm
perl-DBD-MySQL-2.9004-3.1.i386.rpm
perl-DBI-1.40-8.i386.rpm
mysql-4.1.12-3.RHEL4.1.i386.rpm

Again, if you have development packages installed when insalling Linux at the beginning, these packages should be there.

some additional packages:
yum install libpng-devel
yum install libjpeg-devel
yum install libxslt-devel

yum install libcrypt-devel <– without this one make will error out at last step.

Now we can run:
./configure –with-apxs2=/usr/local/apache2/bin/apxs –with-mysql –enable-mbstring –with-curl=/usr/ –enable-exif –with-xsl=/usr/lib/ –with-gd –with-jpeg-dir=/usr/lib/ –with-png-dir=/usr/lib/ –with-zlib-dir=/usr/lib/

make
make install

This entry was posted in server setup. Bookmark the permalink.